Solvedomnisharp vscode v1.23.1 fails to load Unity project, worked with v1.23.0

Issue Description

After upgrading to v1.23.1, I get "Some projects have trouble loading. Please review the output for more details." and autocomplete etc. doesn't work on my Unity 2019.4 project. Restarting vscode does not help.

Downgrading to v1.23.0 fixes it.

Platform: Ubuntu 18.04 with the latest Mono installed from their APT repo deb https://download.mono-project.com/repo/ubuntu stable-bionic main and with dotnet 3.1.401 installed from Microsoft's APT repo.

Logs

OmniSharp log

Starting OmniSharp server at 8/20/2020, 10:06:01 AM Target: /path/to/project/projectname.sln

OmniSharp server started.
Path: /home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/run
PID: 15283

Starting OmniSharp on ubuntu 18.4 (x64)
info: OmniSharp.Services.DotNetCliService
DotNetPath set to dotnet
info: OmniSharp.MSBuild.Discovery.MSBuildLocator
Located 1 MSBuild instance(s)
1: StandAlone 16.8.0 - "/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin"
info: OmniSharp.MSBuild.Discovery.MSBuildLocator
MSBUILD_EXE_PATH environment variable set to '/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/MSBuild.exe'
info: OmniSharp.MSBuild.Discovery.MSBuildLocator
Registered MSBuild instance: StandAlone 16.8.0 - "/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin"
CscToolExe = csc.exe
MSBuildToolsPath = /home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin
CscToolPath = /home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Roslyn
BypassFrameworkInstallChecks = true
MSBuildExtensionsPath = /home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild
info: OmniSharp.Cake.CakeProjectSystem
Detecting Cake files in '/path/to/project'.
info: OmniSharp.Cake.CakeProjectSystem
Could not find any Cake files
info: OmniSharp.MSBuild.ProjectSystem
Detecting projects in '/path/to/project/projectname.sln'.
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/com.unity.multiplayer-hlapi.Runtime.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/UnityEngine.UI.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/UnityEngine.TestRunner.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/Assembly-CSharp.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/com.unity.multiplayer-hlapi.Tests.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/ThirdParty.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/ProjectNameProtoMain.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/GooglePlayGames.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/PxlAssembly.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/PixelIAP.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/Coffee.SoftMaskForUGUI.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/PxlPlayModeTestsAssembly.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/UnityEditor.TestRunner.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/Unity.2D.Sprite.Editor.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/com.unity.multiplayer-hlapi.Editor.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/Coffee.SoftMaskForUGUI.Editor.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/UnityEditor.UI.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/Unity.2D.Tilemap.Editor.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/ThirdParty-Editor.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/Assembly-CSharp-Editor.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/PxlTestsAssembly.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/GooglePlayGamesEditor.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/com.unity.multiplayer-weaver.Editor.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/Unity.VSCode.Editor.csproj'
info: OmniSharp.MSBuild.ProjectManager
Queue project update for '/path/to/project/com.unity.multiplayer-hlapi.EditorTests.csproj'
info: OmniSharp.Script.ScriptProjectSystem
Detecting CSX files in '/path/to/project'.
info: OmniSharp.Script.ScriptProjectSystem
Could not find any CSX files
info: OmniSharp.WorkspaceInitializer
Invoking Workspace Options Provider: OmniSharp.Roslyn.CSharp.Services.CSharpFormattingWorkspaceOptionsProvider, Order: 0
info: OmniSharp.MSBuild.ProjectManager
Loading project: /path/to/project/com.unity.multiplayer-hlapi.Runtime.csproj
info: OmniSharp.WorkspaceInitializer
Invoking Workspace Options Provider: OmniSharp.Roslyn.CSharp.Services.RenameWorkspaceOptionsProvider, Order: 100
info: OmniSharp.WorkspaceInitializer
Invoking Workspace Options Provider: OmniSharp.Roslyn.CSharp.Services.ImplementTypeWorkspaceOptionsProvider, Order: 110
info: OmniSharp.WorkspaceInitializer
Invoking Workspace Options Provider: OmniSharp.Roslyn.CSharp.Services.BlockStructureWorkspaceOptionsProvider, Order: 140
info: OmniSharp.WorkspaceInitializer
Configuration finished.
info: OmniSharp.Stdio.Host
Omnisharp server running using Stdio at location '/path/to/project' on host 14751.
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/com.unity.multiplayer-hlapi.Runtime.csproj'.
/path/to/project/com.unity.multiplayer-hlapi.Runtime.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/UnityEngine.UI.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/UnityEngine.UI.csproj'.
/path/to/project/UnityEngine.UI.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/UnityEngine.TestRunner.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/UnityEngine.TestRunner.csproj'.
/path/to/project/UnityEngine.TestRunner.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/Assembly-CSharp.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/Assembly-CSharp.csproj'.
/path/to/project/Assembly-CSharp.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/com.unity.multiplayer-hlapi.Tests.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/com.unity.multiplayer-hlapi.Tests.csproj'.
/path/to/project/com.unity.multiplayer-hlapi.Tests.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/ThirdParty.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/ThirdParty.csproj'.
/path/to/project/ThirdParty.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/ProjectNameProtoMain.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/ProjectNameProtoMain.csproj'.
/path/to/project/ProjectNameProtoMain.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/GooglePlayGames.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/GooglePlayGames.csproj'.
/path/to/project/GooglePlayGames.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/PxlAssembly.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/PxlAssembly.csproj'.
/path/to/project/PxlAssembly.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/PixelIAP.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/PixelIAP.csproj'.
/path/to/project/PixelIAP.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/Coffee.SoftMaskForUGUI.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/Coffee.SoftMaskForUGUI.csproj'.
/path/to/project/Coffee.SoftMaskForUGUI.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/PxlPlayModeTestsAssembly.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/PxlPlayModeTestsAssembly.csproj'.
/path/to/project/PxlPlayModeTestsAssembly.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/UnityEditor.TestRunner.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/UnityEditor.TestRunner.csproj'.
/path/to/project/UnityEditor.TestRunner.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/Unity.2D.Sprite.Editor.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/Unity.2D.Sprite.Editor.csproj'.
/path/to/project/Unity.2D.Sprite.Editor.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/com.unity.multiplayer-hlapi.Editor.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/com.unity.multiplayer-hlapi.Editor.csproj'.
/path/to/project/com.unity.multiplayer-hlapi.Editor.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/Coffee.SoftMaskForUGUI.Editor.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/Coffee.SoftMaskForUGUI.Editor.csproj'.
/path/to/project/Coffee.SoftMaskForUGUI.Editor.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/UnityEditor.UI.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/UnityEditor.UI.csproj'.
/path/to/project/UnityEditor.UI.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/Unity.2D.Tilemap.Editor.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/Unity.2D.Tilemap.Editor.csproj'.
/path/to/project/Unity.2D.Tilemap.Editor.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/ThirdParty-Editor.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/ThirdParty-Editor.csproj'.
/path/to/project/ThirdParty-Editor.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/Assembly-CSharp-Editor.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/Assembly-CSharp-Editor.csproj'.
/path/to/project/Assembly-CSharp-Editor.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/PxlTestsAssembly.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/PxlTestsAssembly.csproj'.
/path/to/project/PxlTestsAssembly.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/GooglePlayGamesEditor.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/GooglePlayGamesEditor.csproj'.
/path/to/project/GooglePlayGamesEditor.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/com.unity.multiplayer-weaver.Editor.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/com.unity.multiplayer-weaver.Editor.csproj'.
/path/to/project/com.unity.multiplayer-weaver.Editor.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/Unity.VSCode.Editor.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/Unity.VSCode.Editor.csproj'.
/path/to/project/Unity.VSCode.Editor.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Loading project: /path/to/project/com.unity.multiplayer-hlapi.EditorTests.csproj
fail: OmniSharp.MSBuild.ProjectLoader
The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks
[warn]: OmniSharp.MSBuild.ProjectManager
Failed to load project file '/path/to/project/com.unity.multiplayer-hlapi.EditorTests.csproj'.
/path/to/project/com.unity.multiplayer-hlapi.EditorTests.csproj
/home/username/.vscode/extensions/ms-dotnettools.csharp-1.23.1/.omnisharp/1.37.0/omnisharp/.msbuild/Current/Bin/Microsoft.Common.CurrentVersion.targets(1178,5): Error: The reference assemblies for .NETFramework,Version=v4.7.1 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Attempted to update project that is not loaded: /path/to/project/com.unity.multiplayer-hlapi.Runtime.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/UnityEngine.UI.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/UnityEngine.TestRunner.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/Assembly-CSharp.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/com.unity.multiplayer-hlapi.Tests.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/ThirdParty.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/ProjectNameProtoMain.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/GooglePlayGames.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/PxlAssembly.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/PixelIAP.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/Coffee.SoftMaskForUGUI.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/PxlPlayModeTestsAssembly.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/UnityEditor.TestRunner.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/Unity.2D.Sprite.Editor.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/com.unity.multiplayer-hlapi.Editor.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/Coffee.SoftMaskForUGUI.Editor.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/UnityEditor.UI.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/Unity.2D.Tilemap.Editor.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/ThirdParty-Editor.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/Assembly-CSharp-Editor.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/PxlTestsAssembly.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/GooglePlayGamesEditor.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/com.unity.multiplayer-weaver.Editor.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/Unity.VSCode.Editor.csproj
fail: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: /path/to/project/com.unity.multiplayer-hlapi.EditorTests.csproj

C# log

Installing C# dependencies... Platform: linux, x86_64, name=ubuntu, version=18.04

Downloading package 'OmniSharp for Linux (x64)' (47056 KB).................... Done!
Validating download...
Integrity Check succeeded.
Installing package 'OmniSharp for Linux (x64)'

Downloading package '.NET Core Debugger (linux / x64)' (54671 KB).................... Done!
Validating download...
Integrity Check succeeded.
Installing package '.NET Core Debugger (linux / x64)'

Downloading package 'Razor Language Server (Linux / x64)' (52580 KB).................... Done!
Installing package 'Razor Language Server (Linux / x64)'

Finished

Environment information

VSCode version: 1.48.0
C# Extension: 1.23.1

Mono Information OmniSharp using built-in mono
Dotnet Information .NET Core SDK (reflecting any global.json): Version: 3.1.401 Commit: 39d17847db

Runtime Environment:
OS Name: ubuntu
OS Version: 18.04
OS Platform: Linux
RID: ubuntu.18.04-x64
Base Path: /usr/share/dotnet/sdk/3.1.401/

Host (useful for support):
Version: 3.1.7
Commit: fcfdef8d6b

.NET Core SDKs installed:
2.2.402 [/usr/share/dotnet/sdk]
3.0.103 [/usr/share/dotnet/sdk]
3.1.401 [/usr/share/dotnet/sdk]

.NET Core runtimes installed:
Microsoft.AspNetCore.All 2.2.8 [/usr/share/dotnet/shared/Microsoft.AspNetCore.All]
Microsoft.AspNetCore.App 2.2.8 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 3.0.3 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 3.1.7 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 2.2.8 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 3.0.3 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 3.1.7 [/usr/share/dotnet/shared/Microsoft.NETCore.App]

To install additional .NET Core runtimes or SDKs:
https://aka.ms/dotnet-download

Visual Studio Code Extensions
Extension Author Version
cpptools ms-vscode 0.29.0
csharp ms-dotnettools 1.23.1
jsonnet heptio 0.1.0
jsonnet-formatter xrc-inc 0.3.0
unity-debug Unity 2.7.5
vscode-eclipse-keybindings alphabotsec 0.12.0
vscode-proto3 zxh404 0.4.2
33 Answers

✔️Accepted Answer

The problem is that the new .NET Core 3.1 SDK isn't supported by any current Mono release, so the setting "omnisharp.useGlobalMono" has been changed to "never" in 1.23.1 (see changelog https://github.com/OmniSharp/omnisharp-vscode/blob/master/CHANGELOG.md#1231-not-yet-released). This however is incompatible with Mono-based development e.g. Unity.

You can change it back yourself to "omnisharp.useGlobalMono": "always" which should fix your scenario.

Other Answers:

Sample problem here on macOS. It's really annoying that this all of a sudden broke Unity support in VSCode. :-/ This will affect a lot of people, I guess.

Hint for other users: The setting in the OmniSharp config dialog is called "Omnisharp: Use Global Mono". I can confirm that setting this to "always" solved the problem.

The problem is that the new .NET Core 3.1 SDK isn't supported by any current Mono release, so the setting "omnisharp.useGlobalMono" has been changed to "never" in 1.23.1 (see changelog https://github.com/OmniSharp/omnisharp-vscode/blob/master/CHANGELOG.md#1231-not-yet-released). This however is incompatible with Mono-based development e.g. Unity.

I tried all this with no success. Turned out the issue was that were old auto-generated .csproj files from Unity that were confusing VS/C# throughly. Anyone experiencing this I recommend nuking all your .csproj and .sln files and re-opening your project in Unity. The switch to 1.23 for whatever reason started to access those old project files instead.

in VS Code settings (there is an icon to switch to JSON view) or use the option "Omnisharp: Use Global Mono" in the UI view of the settings

Hey guys, calm down, this is in fact a pretty complex tech setup, and I appreciate the work of its maintainers.

I agree with @zachstronaut in one aspect: I'm also struggling every time I want to setup a new Unity project with the C# VSCode extensions. Sometimes it works right away, sometimes just nothing happens (no intellisense, no references). Sometimes, there is only one .sln file being generated, sometimes it's a whole bunch of them. To be honest, I don't have the slightest clue what they are for. (I guess they somehow contain hints about C# assemblies, but I am not really sure.)

It would be awesome to have an in-depth guide that explains the fundamentals of the setup, especially what all these .sln files actually mean and how to trouble-shoot a setup that won't work. The log file outputs of OmniSharp alone are all double Dutch to me. I guess that would be more a task for Unity themselves, but I am not sure how to reach them. Maybe you have direct contacts there so you could address this? Happy to help if you need more explanations from a pure user / Unity dev perspective.

More Issues: