Solvedts node Using nyc (istanbul) with ts-node/register don't check coverage properly in versions from 3.3.0

Using nyc for checking code coverage doesn't cover class field declarations when using ts-node > 3.3.0.
image

Issue description in nyc repository:
istanbuljs/nyc#802

Downgrading ts-node package to version 3.3.0 fixes the issue.

4 Answers

✔️Accepted Answer

@cibergarri Thanks for the response! I'll look into doing a release in the next week or two defaulting the primary mode back to --type-check with --fast being opt-in. External tooling like this makes it trickier to select an appropriate default. The ts-node/register/type-check endpoint will continue existing in all future releases for explicit support.

More Issues: