Solvednvidia docker Ubuntu 17.10: nvidia-docker2 : Depends: docker-ce (= 17.12.0~ce-0~ubuntu) but it is not installable

I need to run Nvidia Jetpack to upgrade my Jetson board.
My workstation runs Ubuntu 17.10.
Jetpack installer requires Ubuntu 16.04. (I can flash from the command line from 17.10, but the actual installer requires 16.04)
So, I want to run the Jetpack installer on 16.04 using nvidia-docker.

I follow the instructions in the README on the nvidia-docker github, but get the following error after adding the repository and keys, and updating, and actually trying to install:

[10:48] jwatte@ripper:~/xenial$ sudo apt-get install -y nvidia-docker2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-docker2 : Depends: docker-ce (= 17.12.0~ce-0~ubuntu) but it is not installable or
                           docker-ee (= 17.12.0~ee-0~ubuntu) but it is not installable
E: Unable to correct problems, you have held broken packages.

The version of docker.io installed on my workstation is:

[10:51] jwatte@ripper:~/xenial$ dpkg -l docker.io
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                             Version               Architecture          Description
+++-================================-=====================-=====================-=====================================================================
ii  docker.io                        1.13.1-0ubuntu6       amd64                 Linux container runtime
[10:51] jwatte@ripper:~/xenial$ dpkg -l docker-ce
dpkg-query: no packages found matching docker-ce

The compatibility matrix says that docker.io is a supported version. (This is the package available for Ubuntu; docker-ce/ee is not.)

36 Answers

✔️Accepted Answer

No, it is supported, but it's just ugly until we add a new virtual package:

sudo apt-get install -y docker.io nvidia-container-runtime=1.1.1+docker1.13.1-1 nvidia-docker2=2.0.2+docker1.13.1-1

Other Answers:

$ sudo apt install nvidia-docker2 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-docker2 : Depends: docker-ce (= 5:18.09.0~3-0~ubuntu-bionic) but it is not installable or
                           docker-ee (= 5:18.09.0~3-0~ubuntu-bionic) but it is not installable
E: Unable to correct problems, you have held broken packages.

I can't install in ubuntu bionic. FAQS says that docker.io is also supported https://github.com/NVIDIA/nvidia-docker/wiki/Frequently-Asked-Questions#which-docker-packages-are-supported

I see how to install docker-ce but I prefer to use docker.io. Could you add docker.io as an alternative dependency to docker-ce or update the FAQ?

More Issues: