SolvedCocoaPods The 'Pods-App' target has transitive dependencies that include static binaries: (*/Pods/GooglePlacePicker/Frameworks/GooglePlacePicker.framework)) during validation

โ„น Please fill out this template when filing an issue.
All lines beginning with an โ„น symbol instruct you with
what info we expect.
Please remove this line and all above before submitting.

Before you start, are you using the latest CocoaPods release?
A lot changes with Xcode releases that are not backwards compatible.

Not an issue about the CocoaPods command line app? Please file an issue in the appropriate repo - https://github.com/CocoaPods
Issues are for feature requests, and bugs; questions should go to Stack Overflow

Using CocoaPods <= 0.39: http://blog.cocoapods.org/Sharding/

Using Xcode 8: Requires CocoaPods 1.1.0 or above.

Issue with Nanaimo not loading:
Please run [sudo] gem uninstall nanaimo and remove all but the latest version.

Issues with pod search? Try deleting your cache rm -rf ~/Library/Caches/CocoaPodsfirst.

Report

What did you do?

Run pod lib lint ANAChat.podspec

What did you expect to happen?
I expect validation to be passed successfully

What happened instead?

Encountered an unknown error (The 'Pods-App' target has transitive dependencies that include static binaries: (*ANAChat/Pods/GooglePlacePicker/Frameworks/GooglePlacePicker.framework)) during validation

CocoaPods Environment

Stack

   CocoaPods : 1.3.1
        Ruby : ruby 2.0.0p648 (2015-12-16 revision 53162) [x86_64-darwin17.2.0]
    RubyGems : 2.7.2
        Host : Mac OS X 10.13.1 (17B48)
       Xcode : 9.1 (9B55)
         Git : git version 2.13.6 (Apple Git-96)
Ruby lib dir : /Users/nowfloats/.rvm/rubies/ruby-2.0.0-p648/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ c638b66c73e1ba627b32eec5c046f49208d35160

Installation Source

Executable Path: /usr/local/bin/pod

Plugins

cocoapods-deintegrate : 1.0.1
cocoapods-plugins     : 1.0.0
cocoapods-search      : 1.0.0
cocoapods-stats       : 1.0.0
cocoapods-trunk       : 1.3.0
cocoapods-try         : 1.1.0

Project that demonstrates the issue

It is a development pod which I'm trying to build.

32 Answers

โœ”๏ธAccepted Answer

I solve my problem using just the specific import that I'm using, for example.
In my SDK I'm using FirebaseCore and FirebaseAnalytics.
Into my class I just import:

import FirebaseCore
import FirebaseAnalytics

And in my .podspec I needed to set static_framework property to true, so my .podspec it's seems like code below:

s.static_framework = true

s.dependency 'Firebase'
s.dependency 'Firebase/Core'

It works for me!

Other Answers:

commenting use_frameworks! fixed the issue for me. Have no idea why.

use_frameworks!

remove this line of your pod file, if you're having this problem, it works for me.

Even after adding the below key to podspec. I'm getting the same error.

s.static_framework = true

error is The 'Pods-App' target has transitive dependencies that include static binaries: (/private/var/folders/ck/b486txj55d171n97wqcg49mw0000gn/T/CocoaPods-Lint-20171122-64905-1jwdftf-*/Pods/GooglePlacePicker/Frameworks/GooglePlacePicker.framework)) during validation.

CocoaPods version 1.3.1 and earlier do not support static framework dependencies.

CocoaPods 1.4.0 adds the static_framework option in #6811 that enables you to specify building a pod as a static_framework, which unlike dynamic frameworks, can have static framework dependencies.

More Issues: