Solvedangular google maps new @types/googlemaps version generates error:

Hello,

After their latest update of @types/googlemaps (5th of October, 2020), I get these 2 errors when I build my Angular10 project for production:

ERROR in node_modules/@agm/core/lib/services/google-maps-api-wrapper.d.ts:51:41 - error TS2314: Generic type 'MapHandlerMap' requires 1 type argument(s).
51 subscribeToMapEvent(eventName: N): Observable<google.maps.MapHandlerMap[N]>;

node_modules/@agm/core/lib/services/google-maps-api-wrapper.d.ts:51:94 - error TS2314: Generic type 'MapHandlerMap' requires 1 type argument(s).
51 subscribeToMapEvent(eventName: N): Observable<google.maps.MapHandlerMap[N]>;

Everything was working fine 2 days ago, with a prior version of @types/googlemaps
Thank you

15 Answers

✔️Accepted Answer

I managed to. Set not ^3.39.12 but 3.39.12

Other Answers:

More Issues: