Solvednativescript cli NativeScript cli error when tns run ios or any command related to IOS platform

From @fawzywassel on October 31, 2017 18:6

cli error =>
NativeScript can only run in Xcode version 6.0 or greater

Copied from original issue: NativeScript/NativeScript#5015

32 Answers

✔️Accepted Answer

I had the same issue and this solved mine

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

reference https://github.com/nodejs/node-gyp/issues/569

More Issues: