Solvedflutter_cached_network_image Library is incompatible with latest Flutter master

Running newest library (1.1.1) and newest Flutter, it produces error:
Error: The method 'CachedNetworkImageProvider.load' has fewer positional arguments than those of overridden method 'ImageProvider.load'

It seems to be related to changes from PR flutter/flutter#41415

16 Answers

βœ”οΈAccepted Answer

I published a quick fix for this as 2.0.0-rc. Wil remove the -rc tag when this flutter version reaches stable. I added a minimum SDK version of 1.10.15-pre.148 as @virskor mentioned that version and I have .151. I couldn't really find the version where this change was introduced.

More Issues: