Solvedreact native onesignal IOS pod install is failing

Hello,

I have problem installing this library. After pod install command following error message is shown:

[!] CocoaPods could not find compatible versions for pod "OneSignal":
  In snapshot (Podfile.lock):
    OneSignal (< 3.0, = 2.12.2, >= 2.9.3)

  In Podfile:
    OneSignal (< 3.6.1, >= 2.9.3)

    react-native-onesignal (from `../node_modules/react-native-onesignal`) was resolved to 3.6.1, which depends on
      OneSignal (= 2.12.3)

Specs satisfying the `OneSignal (< 3.6.1, >= 2.9.3), OneSignal (< 3.0, = 2.12.2, >= 2.9.3), OneSignal (= 2.12.3)` dependency were found, but they required a higher minimum deployment target.

Don't you have any suggestions? Thank you so much!

react-native: 0.61.5
react-native-onesignal: 3.6.1

17 Answers

✔️Accepted Answer

Can you try pod update?

Other Answers:

pod update worked for me. thanks

pod update didn't work for me 🤨 @rgomezp I'm using the new Apple M1 chip..any ideas?

The message persists:

[!] CocoaPods could not find compatible versions for pod "OneSignal":
In Podfile:
OneSignal (< 3.0, >= 2.9.3)

react-native-onesignal (from `../node_modules/react-native-onesignal`) was resolved to 4.0.3, which depends on
  OneSignal (= 3.1.0)

Specs satisfying the OneSignal (< 3.0, >= 2.9.3), OneSignal (= 3.1.0) dependency were found, but they required a higher minimum deployment target.

Thank you so much! pod update is also working for me.

More Issues: