SolvedCarthage How: Please update to the latest Carthage version

When running Carthage, you can receive this warning:

Please update to the latest Carthage version

It will be helpful if this warning also explains HOW to update to the latest Carthage.

12 Answers

✔️Accepted Answer

This command updates brew itself, and does not take formula names.

the command should be brew upgrade carthage

Other Answers:

I don't remember. But if that is the answer then I propose changing

Please update to the latest Carthage version

to

Please update to the latest Carthage version. To do this you will need to remember how you originally installed Carthage.

As of writing this comment the current version is 0.35.0

If brew upgrade carthage command is not working for you, then it means you have not used homebrew during Carthage installation.

So to upgrade using homebrew, use the following steps:

Use which carthage command.

It will show the current path of carthage
In my case it is "/usr/local/bin/carthage".

If you have installed through .pkg then Use these commands to delete every trace of carthage

rm -rf /usr/local/bin/carthage

sudo rm -rf /Library/Frameworks/CarthageKit.framework

Then install fresh carthage
brew install carthage

More Issues: