Solvedultisnips Error detected while processing function UltiSnips#TrackChange[1]..provider#python3#Call: line 18:

I am getting the following error while editing markdown files:

"~/work/miwt-help/en/subMeasurementsHome.markdown" 21L, 970C
Error detected while processing function UltiSnips#TrackChange[1]..provider#python3#Call:
line   18:
Invalid channel: 1
Error detected while processing function UltiSnips#TrackChange[1]..provider#python3#Call:
line   18:
Invalid channel: 1
Error detected while processing function UltiSnips#TrackChange[1]..provider#python3#Call:
line   18:
Invalid channel: 1
"navbar.markdown" 12L, 488C written
Error detected while processing function UltiSnips#TrackChange[1]..provider#python3#Call:
line   18:
Invalid channel: 1
Error detected while processing function UltiSnips#TrackChange[1]..provider#python3#Call:
line   18:
Invalid channel: 1
Error detected while processing function UltiSnips#TrackChange[1]..provider#python3#Call:
line   18:
Invalid channel: 1
Error detected while processing function UltiSnips#TrackChange[1]..provider#python3#Call:
line   18:
Invalid channel: 1
E492: Not an editor command: output
Press ENTER or type command to continue

Every time I hit a key, this error comes up every time I hit a key.

selection_087

36 Answers

✔️Accepted Answer

@hoetmaaiers
I had this exact issue, turns out I have my editor set in my gitconfig

editor = /usr/bin/vim

Instead of the homebrew installed one

editor = /usr/local/bin/vim

switching to the homebrew corrects this.

Other Answers:

I have the same issue in Vim 8 (not Neovim)... Are any solutions known?
I only have the issue when entering a .git/COMMIT_EDITMSG[+].

Same here. No Neovim.

MacOS Sierra v 10.12.5
vim: version 7.4.8056
Homebrew 1.2.3

I'm commenting lines out from augroup UltiSnips_AutoTrigger to augroup END in ~/.vim/plugged/ultisnips/plugin/UltiSnips.vim for now.
For some reason au! UltiSnips_AutoTrigger didn't work. (No group found)

I figured out that re-installing Vim through Homebrew with only python3 does the trick brew install vim --with-python3. Make sure to uninstall python first.

For me brew upgrade vim works as a solution.

More Issues: