SolvedMarlin Ender 3 v1 with 4.2.7 board

I received a creality 4.2.7 motherboard instead of a 1.1.5, but I cannot update marlin 2.0.6.
When I use the Ender 3 Pro 1.5 / Ender 3 v2 configs files, the axes do not work.
And it is impossible to make a home, I have the error "Homing failed" ...
I tried several times to build new firmware, but still not working...

Board Creality v4.2.7

image

image

I have no problem with this firmware: https://mega.nz/file/rNdh2ADZ#DTeOwwJ9YI7EPeQVcyvRzh_EUBuP3T8qa7RcXB8yxqc

image

52 Answers

✔️Accepted Answer

Marlin Firmware to get Creality v4.2.7 boards working perfectly

Steps to help anybody that needs to get this board working ok

Source of this how to: https://github.com/Flawioo/Creality-Ender-3-board-v4.2.7/blob/master/README.md
Visual help: https://youtu.be/OJmE9xwPk1U

Download bugfix from git hub https://github.com/MarlinFirmware/Marlin/archive/bugfix-2.0.x.zip

Download Configuration examples: https://github.com/MarlinFirmware/Configurations/archive/bugfix-2.0.x.zip

In platformio.ini
Change: default_envs = mega2560
To: default_envs = STM32F103RET6_creality

In Configuration.h apply the following settings:

#define MOTHERBOARD BOARD_CREALITY_V427

#define CUSTOM_MACHINE_NAME "Ender-3 32bits" // Or any name you'd like to

#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN // Enable BLTouch probe pins (white and black wires) to be connected to Z-
// --- or ---
#define Z_MIN_PROBE_PIN PB1 // Creality V4.2.7 BLTouch OUT (written on the board)

#define BLTOUCH

#define NOZZLE_TO_PROBE_OFFSET { -40, -10, 0 } // Using this thingfile as mount, measure correctly using your mounted BLTouch https://www.thingiverse.com/thing:3003725

#define PROBING_MARGIN 15 // If you'd want stay away from the edges (higher values goes to center of the bed)

//#define MIN_SOFTWARE_ENDSTOP_Z // To allow to set Z offset values in negative

#define AUTO_BED_LEVELING_BILINEAR

#define LCD_BED_LEVELING

#define Z_SAFE_HOMING

// If you have a runout sensor
#define FILAMENT_RUNOUT_SENSOR

#define NOZZLE_PARK_FEATURE // To change filament

#define NOZZLE_PARK_POINT { (X_MAX_POS - 10), (Y_MIN_POS + 10), 20 } // To change the position of the hotend in front on the right of the bed

In Configuration_adv.h enable the following:

#define BLTOUCH_DELAY 500

#define ADVANCED_PAUSE_FEATURE

#define PARK_HEAD_ON_PAUSE // Park the nozzle during pause and filament change.

#define PINS_DEBUGGING // Only if you'd like to discover new features, if you don't, leave it alone

Compile
In Auto Build Marlin at Visual Studio, click on Build button and wait for the green line
1 succeeded in 00:00:26.355

Where is the firmware I've compiled?
In my case: C:\creality-v4.2.7-marlin-2.0.6-bugfix\Marlin-bugfix-2.0.x.pio\build\STM32F103RET6_creality
In your case: somedir.pio\build\STM32F103RET6_creality

BLTouch pinout on board (5 pins named as BL_T) and respective connections:

Board-----BLTouch wires
G---------Green----Servo
V---------Red------Servo
IN--------Yellow---Servo
G---------White----Probe (if it doesn't work, try to swap with Black)
OUT-------Black----Probe (if you are using Z_MIN_PROBE_PIN 17, if you don't, please just uncomment Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN as above)

image

Runout Sensor plug:

image

Related Issues:

6
Marlin Full graphic controller issues under Arduino >1.0.6
Just hit this with a Tevo Tornado with a MKS GEN L board and RRD Full Graphic Smart Controller tryin...
5
Marlin Extruder fan doesn't come on automatically.
To sum up the intended way to do configuration for the En_AUTO_FAN_PIN settings is to just comment o...
5
Marlin Reprap Discount Full Graphics Smart Controller Display is Garbled
I've tried 0 400 0 and 250 250 250 but nothing changes So here I am again ...
3
Marlin [BUG] TMC2209 Sensorless homing sensitivity is off
@boelle Thank you for reopening it I'm about to close it again but I will update for the benefit of ...
3
Marlin Ender 3 v1 with 4.2.7 board
Marlin Firmware to get Creality v4.2.7 boards working perfectly Steps to help anybody that needs to ...
3
Marlin Marlin with power loss and resume
which firmware version has this bugfix-1.1.x and bugfix-2.0.x how can I activate the feature so I ca...
12
Cura Unable to open any STL in 4.7
It is not very easily hackable but it is possible The following instructions come with no warranty p...
11
meshlab [Ubuntu - Snap] Can't open any file on external hard drive
I had the same issue (also Meshlab 2016.12 running on Ubuntu 16.04) I couldn't open a file under /mn...
4
Cura Z-axis not moving up as it should in new Cura 3.6.0
Great that confirms the bug and it has to be one of the oddest bugs I've seen in a long time ...
3
Cura 2.6 Filament Diameter and Nozzle Temp Ignored
Thanks for reporting I'm using Cura 2.6 on Windows this is a clean install with no previous profiles...
3
Cura [3.5] Temperature is not correct in the GCode
Does M104 S{material_print_temperature 0} work for you? I Have the following entry in the Start GCod...
42
arduino esp32 WiFiClientSecure make issue
This seemed to work for me make menuconfig Good luck. Hardware: (Doesn't matter for this issue !) Bo...
22
arduino esp32 Task watchdog got triggered. The following tasks did not feed the watchdog in time
Anyone who still want to avoid that error should try adding these three line to your continuous rtos...
21
Arduino Use proper configuration files location on linux
Updating numerous web pages that mention the existing location doesn't seem like such a nice task an...
18
arduino esp32 How can I turn off the radio on ESP32?
There is an example for this: https://github.com/espressif/arduino-esp32/blob/master/libraries/WiFi/...
16
johnny five Browserify / Webpack support
I just ran into this issue At a high level the goal here would be to make requiring johnny-five in p...
15
arduino esp32 tone was not declared in this scope
I think tone is part of the ledc functions in esp32 I don't have a speaker around to test but try th...
12
arduino esp32 SmartConfig fails connection - appears not saving SSID
@dhernandezgt for it to reconnect automatically on boot Hardware: Board: ESP32 Core Dev Module Gener...
12
arduino esp32 hostname can not set
I change the order of Statement ,than it is worked. Please fill the info fields it helps to get you ...
10
arduino esp32 unreliable connecting to wifi
I had the exact same problem and it drove me crazy for ages It all started when I added a 2nd Wifi m...
8
Tasmota MagicHome LED (ESP-IR-B-v2.3 / ESP8285MOD ESP-M2) not working with tasmota f/w
Well I worked mine out Color order was just a case of switching the PWM1 and PWM2 because my LED str...
8
arduino esp32 FSBrowser problem
Try this comment out in webserver.cpp Hardware: Board: ESP32 wroom32 Core Installation/update date: ...
7
Arduino Menu don't show up in OSX High Sierra Menubar
I found a simpler workaround Force the language to English for the .app Open a Terminal and run: def...
7
Tasmota More effects with leds
Hello everyone First of all thank you for this wonderful library I have found it very useful ...
7
arduino esp32 Simultaneously use the two I2C bus of the ESP32.
Thanks beegee-tokyo With your help i could modify a I2C Scanner to this dual channel I2C Scanner Tes...
6
arduino esp32 Missing branch #idf-release/v4.0
Because i had to get this working for a commercial application too i have forked a recent fork of th...
6
homie esp8266 [develop-v3] OTA failing
Hey guys I found the problem and learned a few things along the way The hardware WD timer was being ...
5
Tasmota lc technology 2ch relay
Closing issue as there is no feedback Please when you have time tell us if the proposed solution wor...
5
Tasmota Upgrade to Tasmota from Shelly mongoose trough SW ( not cable)
@seritos - it seems that the upload to the ftp server did not work for some builds but the actions w...
5
Tasmota Alternative PWM implementation for ESP8266 devices
Hi All I know this is an old issue This thread came up when I was looking to use Tasmota to control ...
5
arduino esp32 Server ota updates
Has anyone been able to do something like this to update ESP32 firmware through a URL: ESPhttpUpdate...
5
platformio core Debug by CLion
Hi all There is a piece of good news here We are so happy to present the first MVP of the PlatformIO...
4
Arduino Arduino IDE 1.6.5/1.6.8 Mac OS X 10.11/10.11.3 -- Error downloading package_index.json
@shanetoven @remct Could you please try deleting ~/Library/Arduino15/package_index.json and restarti...
4
arduino esp32 Touch Examples
first do not read the touch pins in the loop Then instead of that set in the interrupts a boolean fl...
4
arduino esp32 How can I reset Serial2 / UART2?
I propose a change in the Serial.flush function to avoid the trouble with serial2 ...
4
arduino esp32 Onewire & Wifi Problems
@cristianhumelnicu as I posted up above portDISABLE_INTERRUPTS() is called before you do the tempera...
4
TinyGSM Library not working with ESP32 hardware Serial2
@vshymanskyy sorry for the untidiness I have quickly assembled this example to download .bin server ...
3
Tasmota Alexa issue
You can try setoption41 40 PROBLEM DESCRIPTION I have been using the Tasmota version 6.3.0 for about...
3
Tasmota multiple switchtopics?
As you are running WITHOUT a relay it is not a sonoff and therefore anything could happen but appare...
3
IRremoteESP8266 Adding Support for Carrier AC 72 bit
I added some debug messages to see why 56 bit swing send does not work and so far I confirmed that t...
3
IRremoteESP8266 Sending Raw as hex, possible timing issues.
You probably won't love my solution but because the infoglobe protocol does not have both spaces and...
3
arduino esp32 Router connection: 50% failure (50% success)
@me-no-dev I suggest re-opening this issue as I am still getting this problem I am using the MH-ET L...
5
nodemcu firmware Policy of supporting Lua in ROM
OK It looks as if I have ironed out most of the issues and can put together an evaluation PR ...
4
nodemcu firmware Upgrade to SDK 3.0 -- update 1
I'll do the proper PR today or tomorrow Sorry guys but I've been a bit poorly and this has hit my ab...
3
esp32 snippets ESP32 BLE does not connect to Bluetooth LE Lamp (Magic Blue)
After investigating more time I've found the problem The signature of BLEClient->connect is the foll...
3
nodemcu firmware enduser_setup "Handling POST" failure on 310faf7 and dev
Can we roll back to the version in 2.2.0.0 for the next drop to master giving someone with motivatio...
4
fwupd Can't update logitech unifying receiver: cannot handle firmware requirement 'not-child'
I have actually managed to install RQR24.06_B0030 by myself Here is what i did: Comment out lines 62...
3
Heimdall unable to compile from source
If you just want the command line tool then compilation (and download times) can be sped up ...
3
GalaxyBudsClient Linux port?
The port is mostly finished Some stuff such as the tray bar integration is still missing but this sh...
3831
axios Axios catch error returns javascript error not server response
I have exactly the same environment Try this: Modify from console.log(error) to console.log(error.re...