Solvedangular cli Cannot find module '@angular/tsc-wrapped/src/tsc'

Please provide us with the following information:

OS?

Windows 7, 8 or 10. Linux (which distribution). Mac OSX (Yosemite? El Capitan?)

Mac OsX 10.11.6

Versions.

Please run ng --version. If there's nothing outputted, please run in a Terminal: node --version and paste the result here:

ng --version gives this error: Cannot find module '@angular/tsc-wrapped/src/tsc'

Repro steps.

Was this an app that wasn't created using the CLI? What change did you do on your code? etc.

Mention any other details that might be useful.

Followed the tutorial to update cli. Now it is broken on all ng commands...


Thanks! We'll be in touch soon.

32 Answers

✔️Accepted Answer

@iaashish i was facing issue - tried following and it worked
reinstalled npm to latest version
npm uninstall -g angular-cli
npm cache clean
npm install -g angular-cli@latest

Other Answers:

npm install @angular/tsc-wrapped autoprefixer

I had the same kind of problem using CircleCI. Tried a few different things. I got it to work eventually by installing the missing dependencies by hand in circle.yml. It's odd that this works without any problems on my Mac.

I don't have the time to research this more, but my feeling is that something isn't correctly installed on some systems. Apparently the @angular/tsc-wrapped and autoprefixer are not installed when npm install is run. Doing this manually before building fixes this.

  pre:
    - npm install -g angular-cli
    - npm install @angular/tsc-wrapped autoprefixer

Maybe someone with some more in-depth knowledge can look into this? I assume this is isolated to angular-cli, not a general problem with angular or tools involved.

Doing "npm install @angular/tsc-wrapped autoprefixer" as @snagar78 said fixed the issue :)

Same here :-(
None of these solutions worked for me...

Sorry for the late reaction.
tx @JimTheMan

for me the "npm install @angular/tsc-wrapped autoprefixer" part worked, i quess
because II did a lot of things, you know how it works..., thus I'm not sure ...

More Issues: