Solvedrasa Can't install tensorflow v1.15.0 from requirements.txt

Collecting tensorflow~=1.15.0 (from rasa==1.5.0a1)
  Could not find a version that satisfies the requirement tensorflow~=1.15.0 (from rasa==1.5.0a1) (from versions: 0.12.1, 1.0.0, 1.0.1, 1.1.0rc0, 1.1.0rc1, 1.1.0rc2, 1.1.0, 1.2.0rc0, 1.2.0rc1, 1.2.0rc2, 1.2.0, 1.2.1, 1.3.0rc0, 1.3.0rc1, 1.3.0rc2, 1.3.0, 1.4.0rc0, 1.4.0rc1, 1.4.0, 1.4.1, 1.5.0rc0, 1.5.0rc1, 1.5.0, 1.5.1, 1.6.0rc0, 1.6.0rc1, 1.6.0, 1.7.0rc0, 1.7.0rc1, 1.7.0, 1.7.1, 1.8.0rc0, 1.8.0rc1, 1.8.0, 1.9.0rc0, 1.9.0rc1, 1.9.0rc2, 1.9.0, 1.10.0rc0, 1.10.0rc1, 1.10.0, 1.10.1, 1.11.0rc0, 1.11.0rc1, 1.11.0rc2, 1.11.0, 1.12.0rc0, 1.12.0rc1, 1.12.0rc2, 1.12.0, 1.12.2, 1.12.3, 1.13.0rc0, 1.13.0rc1, 1.13.0rc2, 1.13.1, 1.13.2, 1.14.0rc0, 1.14.0rc1, 1.14.0, 2.0.0a0, 2.0.0b0, 2.0.0b1)
27 Answers

✔️Accepted Answer

Got this working!

sudo curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
python3 get-pip.py

Installing collected packages: pip
Found existing installation: pip 9.0.1
Uninstalling pip-9.0.1:
Successfully uninstalled pip-9.0.1
Successfully installed pip-19.3.1

Then:
pip3 install rasa

Other Answers:

You can upgrade PIP by removing the system python-package and then running:
sudo python3 -m pip install --upgrade pip

You can install it locally with "--user" but the system wide installation for PIP is the recommended AFAIK.

@AmalM7 can you run: pip --version just to be sure about it?

More Issues: